import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[[:alpha:]]|[ \\-\\'])+$";
final String string = "Alexander\n"
+ "Musin-Pushkin\n"
+ "D'Artagnan\n"
+ "Александр\n"
+ "Тёркин\n"
+ "François\n"
+ "Maček\n"
+ "José\n"
+ "Jürgen\n"
+ "Жан жак\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}