import Foundation
let pattern = #"<pop title="([a-zA-Z0-9]+)">dolor<\/pop>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<p><pop title="test">Lorem</pop> ipsum <pop title="dekisha">dolor</pop> sit amet, adipiscing <pop title="test">dolor</pop> elit. Cras at aliquam enim. Curabitur nisi nunc, tincidunt et efficitur ut, finibus eu arcu. Maecenas aliquam nisl sed erat ultrices venenatis. Orci varius natoque <pop title="test">dolor</pop> penatibus <pop title="test">dolor</pop> et magnis dis parturient montes, nascetur ridiculus mus. In sed semper nisi. Ut quis sapien pharetra, volutpat arcu id, mollis lacus. Duis lacus dui, laoreet ac rutrum non, aliquam sit amet mi. Donec a quam ut tortor ornare mattis et a dui. Mauris non mauris est. Etiam arcu ante, condimentum mattis cursus ac, vestibulum quis nulla. Etiam vehicula, arcu ac pretium feugiat, tellus eros pellentesque quam, at pulvinar ligula turpis eget lectus. Phasellus vitae turpis augue.</p>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)