use strict;
my $str = '<p><pop title="test">Lorem</pop> ipsum <pop title="dekisha">dolor</pop> sit amet, adipiscing <pop title="test">dolor</pop> elit. Cras at aliquam enim. Curabitur nisi nunc, tincidunt et efficitur ut, finibus eu arcu. Maecenas aliquam nisl sed erat ultrices venenatis. Orci varius natoque <pop title="test">dolor</pop> penatibus <pop title="test">dolor</pop> et magnis dis parturient montes, nascetur ridiculus mus. In sed semper nisi. Ut quis sapien pharetra, volutpat arcu id, mollis lacus. Duis lacus dui, laoreet ac rutrum non, aliquam sit amet mi. Donec a quam ut tortor ornare mattis et a dui. Mauris non mauris est. Etiam arcu ante, condimentum mattis cursus ac, vestibulum quis nulla. Etiam vehicula, arcu ac pretium feugiat, tellus eros pellentesque quam, at pulvinar ligula turpis eget lectus. Phasellus vitae turpis augue.</p>';
my $regex = qr/<pop title="([a-zA-Z0-9]+)">dolor<\/pop>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}