// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<pop title="([a-zA-Z0-9]+)">dolor<\/pop>"#).unwrap();
let string = "<p><pop title=\"test\">Lorem</pop> ipsum <pop title=\"dekisha\">dolor</pop> sit amet, adipiscing <pop title=\"test\">dolor</pop> elit. Cras at aliquam enim. Curabitur nisi nunc, tincidunt et efficitur ut, finibus eu arcu. Maecenas aliquam nisl sed erat ultrices venenatis. Orci varius natoque <pop title=\"test\">dolor</pop> penatibus <pop title=\"test\">dolor</pop> et magnis dis parturient montes, nascetur ridiculus mus. In sed semper nisi. Ut quis sapien pharetra, volutpat arcu id, mollis lacus. Duis lacus dui, laoreet ac rutrum non, aliquam sit amet mi. Donec a quam ut tortor ornare mattis et a dui. Mauris non mauris est. Etiam arcu ante, condimentum mattis cursus ac, vestibulum quis nulla. Etiam vehicula, arcu ac pretium feugiat, tellus eros pellentesque quam, at pulvinar ligula turpis eget lectus. Phasellus vitae turpis augue.</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}