import Foundation
let pattern = #"^(https:\/\/)*(localhost|airhelp.com)\/(?!en|nl|pt).*\/.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/en/airlines/
localhost/en-gb/airlines/
localhost/en-gb/
localhost/pl/
localhost/nl/
localhost/pt/
localhost/pt-br/
airhelp.com/pl/
airhelp.com/en/
airhelp.com/en-gb/
airhelp.com/pt/
airhelp.com/pl/airlines/dupa
https://localhost/en/
https://localhost/en-gb/
https://localhost/pl/
https://localhost/nl/
https://localhost/pt/
https://localhost/pt-br/
https://airhelp.com/pl/
https://airhelp.com/en/
https://airhelp.com/en-gb/
https://airhelp.com/pt/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)