#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https:\/\/)*(localhost|airhelp.com)\/(?!en|nl|pt).*\/.*$"
Local $sString = "/en/airlines/" & @CRLF & _
"localhost/en-gb/airlines/" & @CRLF & _
"localhost/en-gb/" & @CRLF & _
"localhost/pl/" & @CRLF & _
"localhost/nl/" & @CRLF & _
"localhost/pt/" & @CRLF & _
"localhost/pt-br/" & @CRLF & _
"airhelp.com/pl/" & @CRLF & _
"airhelp.com/en/" & @CRLF & _
"airhelp.com/en-gb/" & @CRLF & _
"airhelp.com/pt/" & @CRLF & _
"airhelp.com/pl/airlines/dupa" & @CRLF & _
"" & @CRLF & _
"https://localhost/en/" & @CRLF & _
"https://localhost/en-gb/" & @CRLF & _
"https://localhost/pl/" & @CRLF & _
"https://localhost/nl/" & @CRLF & _
"https://localhost/pt/" & @CRLF & _
"https://localhost/pt-br/" & @CRLF & _
"https://airhelp.com/pl/" & @CRLF & _
"https://airhelp.com/en/" & @CRLF & _
"https://airhelp.com/en-gb/" & @CRLF & _
"https://airhelp.com/pt/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")