using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https:\/\/)*(localhost|airhelp.com)\/(?!en|nl|pt).*\/.*$";
string input = @"/en/airlines/
localhost/en-gb/airlines/
localhost/en-gb/
localhost/pl/
localhost/nl/
localhost/pt/
localhost/pt-br/
airhelp.com/pl/
airhelp.com/en/
airhelp.com/en-gb/
airhelp.com/pt/
airhelp.com/pl/airlines/dupa
https://localhost/en/
https://localhost/en-gb/
https://localhost/pl/
https://localhost/nl/
https://localhost/pt/
https://localhost/pt-br/
https://airhelp.com/pl/
https://airhelp.com/en/
https://airhelp.com/en-gb/
https://airhelp.com/pt/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}