re = /^https?:\/\/(?:.*\.)?(.*?)\..*/m
str = 'http://www.google.com/
http://google.com
https://bing.com/
https://yandex.ru/abc123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end