$re = '/^https?:\/\/(?:.*\.)?(.*?)\..*/m';
$str = 'http://www.google.com/
http://google.com
https://bing.com/
https://yandex.ru/abc123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);