package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?:\/\/(?:.*\.)?(.*?)\..*`)
var str = `http://www.google.com/
http://google.com
https://bing.com/
https://yandex.ru/abc123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}