using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(?!(https*://)*((127)|(192\.168)|(0\.0\.0\.0)))(?:(?:https*://)|^))(?:(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2})\.(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2})\.(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2})\.(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2}))(?=[^\d\s]|$)";
string input = @"http://127.0.0.1
127.0.0.1
http://192.168.0.155
192.168.0.155
https://0.0.0.0
25.61.12.6
http://193.168.0.155
http://148.251.8.11
115.148.63.10";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}