#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=(?!(https*://)*((127)|(192\.168)|(0\.0\.0\.0)))(?:(?:https*://)|^))(?:(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2})\.(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2})\.(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2})\.(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2}))(?=[^\d\s]|$)"
Local $sString = "http://127.0.0.1" & @CRLF & _
"127.0.0.1" & @CRLF & _
"http://192.168.0.155" & @CRLF & _
"192.168.0.155" & @CRLF & _
"https://0.0.0.0" & @CRLF & _
"" & @CRLF & _
"25.61.12.6" & @CRLF & _
"http://193.168.0.155" & @CRLF & _
"http://148.251.8.11" & @CRLF & _
"115.148.63.10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")