re = /(?<=(?!(https*:\/\/)*((127)|(192\.168)|(0\.0\.0\.0)))(?:(?:https*:\/\/)|^))(?:(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2})\.(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2})\.(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2})\.(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2}))(?=[^\d\s]|$)/m
str = 'http://127.0.0.1
127.0.0.1
http://192.168.0.155
192.168.0.155
https://0.0.0.0
25.61.12.6
http://193.168.0.155
http://148.251.8.11
115.148.63.10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end