use strict;
my $str = '12976000673:Marcel da Costa
1239583003:Sergio Schiavinatto Silva
12981149464:Camila Rodrigues
12991633389:Silvio Carlos
1239587535:Jose Antonio
12981621899:Roberto Andrea
12974087508:Isaias Monteiro
12974052936:Mariza Innocente
1239533666:Rubens Sebastiao
12981258115:Nilberto de Almeida
12997796868:Rubens Amancio
1139582099:Jorge Abrao
1139583003:Luiz Carlos
1239214446:Abrao Gassul
12991018779:Joao Pedro
1239582099:Bastiao Silva
1210408957:Pedro de Santos
1239587511:Carlos Maya
1239517008
12981331001
1239581490
12981230081
12991633389
12981356840
12981356529
12981356844
12981258115
12997796868
12981455770
12997171890
12997182987
1139539755
1239529338
1239539755
12976000673
1260032061
1236314341';
my $regex = qr/\d{1,11}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}