#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{1,11}"
Local $sString = "12976000673:Marcel da Costa" & @CRLF & _
"1239583003:Sergio Schiavinatto Silva" & @CRLF & _
"12981149464:Camila Rodrigues" & @CRLF & _
"12991633389:Silvio Carlos" & @CRLF & _
"1239587535:Jose Antonio" & @CRLF & _
"12981621899:Roberto Andrea" & @CRLF & _
"12974087508:Isaias Monteiro" & @CRLF & _
"12974052936:Mariza Innocente" & @CRLF & _
"1239533666:Rubens Sebastiao" & @CRLF & _
"12981258115:Nilberto de Almeida" & @CRLF & _
"12997796868:Rubens Amancio" & @CRLF & _
"1139582099:Jorge Abrao" & @CRLF & _
"1139583003:Luiz Carlos" & @CRLF & _
"1239214446:Abrao Gassul" & @CRLF & _
"12991018779:Joao Pedro" & @CRLF & _
"1239582099:Bastiao Silva" & @CRLF & _
"1210408957:Pedro de Santos" & @CRLF & _
"1239587511:Carlos Maya" & @CRLF & _
"1239517008" & @CRLF & _
"12981331001" & @CRLF & _
"1239581490" & @CRLF & _
"12981230081" & @CRLF & _
"12991633389" & @CRLF & _
"12981356840" & @CRLF & _
"12981356529" & @CRLF & _
"12981356844" & @CRLF & _
"12981258115" & @CRLF & _
"12997796868" & @CRLF & _
"12981455770" & @CRLF & _
"12997171890" & @CRLF & _
"12997182987" & @CRLF & _
"1139539755" & @CRLF & _
"1239529338" & @CRLF & _
"1239539755" & @CRLF & _
"12976000673" & @CRLF & _
"1260032061" & @CRLF & _
"1236314341"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")