$re = '/^dog$/m';
$str = 'only exact word in a phrase dog 123
dog
super dog ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);