package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^dog$`)
var str = `only exact word in a phrase dog 123
dog
super dog `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}