using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^dog$";
string input = @"only exact word in a phrase dog 123
dog
super dog ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}