import Foundation
let pattern = #"(?:http://|https://)?(?:www\.)?cfx\.re/join/[a-z0-9:]{6}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
cfx.re/join/98e8ob
http://cfx.re/join/ydpmy9
https://cfx.re/join/bkomed
cfx.re/join/98e8oB
cfx.re/join/98e8obb
cfx.re/join/98e8o
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)