$re = '/(?:http://|https://)?(?:www\.)?cfx\.re/join/[a-z0-9:]{6}$/m';
$str = 'cfx.re/join/98e8ob
http://cfx.re/join/ydpmy9
https://cfx.re/join/bkomed
cfx.re/join/98e8oB
cfx.re/join/98e8obb
cfx.re/join/98e8o';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);