use strict;
my $str = 'cfx.re/join/98e8ob
http://cfx.re/join/ydpmy9
https://cfx.re/join/bkomed
cfx.re/join/98e8oB
cfx.re/join/98e8obb
cfx.re/join/98e8o';
my $regex = qr/(?:http://|https://)?(?:www\.)?cfx\.re/join/[a-z0-9:]{6}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}