re = /(?=\w{6,})(?=\w*\d{2})/mi
str = 'bana12
abc123
8pass99
astr1on11aut
banan1
astronaut
12345
1a2bcde'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end