$re = '/(?=\w{6,})(?=\w*\d{2})/mi';
$str = 'bana12
abc123
8pass99
astr1on11aut
banan1
astronaut
12345
1a2bcde';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);