import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\w{6,})(?=\\w*\\d{2})";
final String string = "bana12\n"
+ "abc123\n"
+ "8pass99\n"
+ "astr1on11aut\n\n"
+ "banan1\n"
+ "astronaut\n"
+ "12345\n"
+ "1a2bcde";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}