# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b([^\s\"]+)(\s+|)\:=\s+new\s+([^(]+)\(([^;\(\)]+)\);"
test_str = ("create or replace package body ORA_MTK.Test_package_03 as\n"
"procedure do_something (n1 in NUMBER, n2 in out NUMBER,n3 in out NOCOPY NUMBER) as\n\n"
"aaa11 ty_base := new ty_base();\n\n"
"l_array12 tyt_base := new tyt_base(ty_base(1,2,3));\n\n"
"aaa13 ty_base:= new ty_base(participantid => 'a',clientid => '1',price => 3);\n\n"
"begin\n"
" aaa11 ty_base := new ty_base();\n\n"
" l_array12 tyt_base := new tyt_base(ty_base(1,2,3));\n\n"
" l_array13 := new tyt_base(ty_base(1,2,3));\n\n"
" aaa13 := new ty_base(participantid => 'a',clientid => '1',price => 3);\n\n"
" aaa14 := new ty_base(participantid => 'a', -- comment 01\n"
" clientid => '1' -- comment 01 ; ,\n"
" ,price => 3);\n"
" aaa15 := new ty_base(participantid15 => 'a', -- comment 01\n"
" -- comment 02;\n"
" clientid15 => '1'\n"
" ,price15 => 3);\n"
" \n"
" aaa16.xxxx := new ty_base(participantid => 'a',clientid => '1',price => 3);\n"
" \n"
" l_array(l_array.count) := NEW ty_base(participantid => 300,clientid => 2,price => 3);\n"
" l_array(l_array.count).xxxx := NEW ty_base(participantid => 300,clientid => 2,price => 3);\n"
" \"aaa 17\" := new ty_base(participantid => 'a',clientid => '1',price => 3);\n"
"end do_something;\n\n"
"end Test_package_03")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.