using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([^\s\""]+)(\s+|)\:=\s+new\s+([^(]+)\(([^;\(\)]+)\);";
string input = @"create or replace package body ORA_MTK.Test_package_03 as
procedure do_something (n1 in NUMBER, n2 in out NUMBER,n3 in out NOCOPY NUMBER) as
aaa11 ty_base := new ty_base();
l_array12 tyt_base := new tyt_base(ty_base(1,2,3));
aaa13 ty_base:= new ty_base(participantid => 'a',clientid => '1',price => 3);
begin
aaa11 ty_base := new ty_base();
l_array12 tyt_base := new tyt_base(ty_base(1,2,3));
l_array13 := new tyt_base(ty_base(1,2,3));
aaa13 := new ty_base(participantid => 'a',clientid => '1',price => 3);
aaa14 := new ty_base(participantid => 'a', -- comment 01
clientid => '1' -- comment 01 ; ,
,price => 3);
aaa15 := new ty_base(participantid15 => 'a', -- comment 01
-- comment 02;
clientid15 => '1'
,price15 => 3);
aaa16.xxxx := new ty_base(participantid => 'a',clientid => '1',price => 3);
l_array(l_array.count) := NEW ty_base(participantid => 300,clientid => 2,price => 3);
l_array(l_array.count).xxxx := NEW ty_base(participantid => 300,clientid => 2,price => 3);
""aaa 17"" := new ty_base(participantid => 'a',clientid => '1',price => 3);
end do_something;
end Test_package_03";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}