import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b([^\\s\\\"]+)(\\s+|)\\:=\\s+new\\s+([^(]+)\\(([^;\\(\\)]+)\\);";
final String string = "create or replace package body ORA_MTK.Test_package_03 as\n"
+ "procedure do_something (n1 in NUMBER, n2 in out NUMBER,n3 in out NOCOPY NUMBER) as\n\n"
+ "aaa11 ty_base := new ty_base();\n\n"
+ "l_array12 tyt_base := new tyt_base(ty_base(1,2,3));\n\n"
+ "aaa13 ty_base:= new ty_base(participantid => 'a',clientid => '1',price => 3);\n\n"
+ "begin\n"
+ " aaa11 ty_base := new ty_base();\n\n"
+ " l_array12 tyt_base := new tyt_base(ty_base(1,2,3));\n\n"
+ " l_array13 := new tyt_base(ty_base(1,2,3));\n\n"
+ " aaa13 := new ty_base(participantid => 'a',clientid => '1',price => 3);\n\n"
+ " aaa14 := new ty_base(participantid => 'a', -- comment 01\n"
+ " clientid => '1' -- comment 01 ; ,\n"
+ " ,price => 3);\n"
+ " aaa15 := new ty_base(participantid15 => 'a', -- comment 01\n"
+ " -- comment 02;\n"
+ " clientid15 => '1'\n"
+ " ,price15 => 3);\n"
+ " \n"
+ " aaa16.xxxx := new ty_base(participantid => 'a',clientid => '1',price => 3);\n"
+ " \n"
+ " l_array(l_array.count) := NEW ty_base(participantid => 300,clientid => 2,price => 3);\n"
+ " l_array(l_array.count).xxxx := NEW ty_base(participantid => 300,clientid => 2,price => 3);\n"
+ " \"aaa 17\" := new ty_base(participantid => 'a',clientid => '1',price => 3);\n"
+ "end do_something;\n\n"
+ "end Test_package_03";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}