const regex = /((?:(?(?=Fig\.|\d+\.\d).+?(?=\s)|[^.!?])+(?=\.))+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:(?(?=Fig\\.|\\d+\\.\\d).+?(?=\\s)|[^.!?])+(?=\\.))+)', 'gi')
const str = `This sentence should be captured because it contains the number 20.
This sentence should be captured because it contains the reference term 20AA.
This sentence should not be captured because it does not contain a number or reference term.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}