import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:(?(?=Fig\\.|\\d+\\.\\d).+?(?=\\s)|[^.!?])+(?=\\.))+)";
final String string = "This sentence should be captured because it contains the number 20. \n\n"
+ "This sentence should be captured because it contains the reference term 20AA. \n\n"
+ "This sentence should not be captured because it does not contain a number or reference term.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}