# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r":smile_([0-9]{0,2}):"
test_str = (":smile_1:\n"
":smile_2:\n"
":smile_3:\n"
":smile_4:\n"
":smile_5:\n"
":smile_6:\n"
":smile_7:\n"
":smile_8:\n"
":smile_9:\n"
":smile_10:\n"
":smile_11:\n"
":smile_12:\n"
":smile_100:")
subst = "<img src=\"/$1.png\">"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.