# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/:smile_([0-9]{0,2}):/<img src="\/$1.png">/g;t' <<< ":smile_1:
:smile_2:
:smile_3:
:smile_4:
:smile_5:
:smile_6:
:smile_7:
:smile_8:
:smile_9:
:smile_10:
:smile_11:
:smile_12:
:smile_100:"