$re = '/:smile_([0-9]{0,2}):/';
$str = ':smile_1:
:smile_2:
:smile_3:
:smile_4:
:smile_5:
:smile_6:
:smile_7:
:smile_8:
:smile_9:
:smile_10:
:smile_11:
:smile_12:
:smile_100:';
$subst = "<img src=\"/$1.png\">";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;