import Foundation
let pattern = #"\b[\s(.)\d-]{6,}\d\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
hola me llamo juana mi número es el 692147849 tengo otro número 692 14 15 16 y tengo otro más el 692.123.123
y el otro número es el 968 23 43 45 fasdf y el núḿero 968 123 123 y si ahora pongo http://www.laweb.es/12/24/323/323/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)