# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b[\s(.)\d-]{6,}\d\b"
test_str = ("hola me llamo juana mi número es el 692147849 tengo otro número 692 14 15 16 y tengo otro más el 692.123.123\n\n"
"y el otro número es el 968 23 43 45 fasdf y el núḿero 968 123 123 y si ahora pongo http://www.laweb.es/12/24/323/323/")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.