import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[\\s(.)\\d-]{6,}\\d\\b";
final String string = "hola me llamo juana mi número es el 692147849 tengo otro número 692 14 15 16 y tengo otro más el 692.123.123\n\n"
+ "y el otro número es el 968 23 43 45 fasdf y el núḿero 968 123 123 y si ahora pongo http://www.laweb.es/12/24/323/323/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}