re = /(([012][0-9])|(3[01]))\/([0]{0,1}[1-9]|1[012])\/\d{4} ([01][0-9]|[2][0-3]):([01345][0-9])/
str = '30/09/1979 12:59'
# Print the match result
str.match(re) do |match|
puts match.to_s
end