const regex = /(([012][0-9])|(3[01]))\/([0]{0,1}[1-9]|1[012])\/\d{4} ([01][0-9]|[2][0-3]):([01345][0-9])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([012][0-9])|(3[01]))\\\/([0]{0,1}[1-9]|1[012])\\\/\\d{4} ([01][0-9]|[2][0-3]):([01345][0-9])', '')
const str = `30/09/1979 12:59`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}