package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([012][0-9])|(3[01]))\/([0]{0,1}[1-9]|1[012])\/\d{4} ([01][0-9]|[2][0-3]):([01345][0-9])`)
var str = `30/09/1979 12:59`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}