# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*?) = { Hash=(?P<hash>\d*), X=(?P<x>\d*), Y=(?P<y>\d*), Rot=(?P<rot>\d*), Flip=(?P<flip>\d*), Var=(?P<var>\d*) }"
test_str = ("Language = \"Traditional Chinese\"\n"
"Hideout Name = \"藏身處 - 羅雀後街\"\n"
"Hideout Hash = 62635\n\n"
"倉庫 = { Hash=3230065491, X=265, Y=227, Rot=0, Flip=0, Var=0 }\n"
"公會倉庫 = { Hash=139228481, X=340, Y=231, Rot=15326, Flip=0, Var=0 }\n"
"傳送點 = { Hash=1224707366, X=298, Y=385, Rot=22179, Flip=0, Var=1 }\n"
"工藝台 = { Hash=2059629901, X=308, Y=288, Rot=32768, Flip=0, Var=4 }\n"
"黃金地球儀 = { Hash=2306038834, X=298, Y=227, Rot=0, Flip=0, Var=0 }\n"
"娜瓦莉 = { Hash=693228958, X=322, Y=260, Rot=32768, Flip=0, Var=0 }\n"
"埃哈 = { Hash=2684274993, X=325, Y=191, Rot=34826, Flip=0, Var=0 }\n"
"艾瓦 = { Hash=2115859440, X=265, Y=207, Rot=16384, Flip=0, Var=0 }\n"
"赫蓮娜 = { Hash=845403974, X=314, Y=238, Rot=47093, Flip=0, Var=0 }")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.