#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?) = { Hash=(?P<hash>\d*), X=(?P<x>\d*), Y=(?P<y>\d*), Rot=(?P<rot>\d*), Flip=(?P<flip>\d*), Var=(?P<var>\d*) }"
Local $sString = "Language = "Traditional Chinese"" & @CRLF & _
"Hideout Name = "藏身處 - 羅雀後街"" & @CRLF & _
"Hideout Hash = 62635" & @CRLF & _
"" & @CRLF & _
"倉庫 = { Hash=3230065491, X=265, Y=227, Rot=0, Flip=0, Var=0 }" & @CRLF & _
"公會倉庫 = { Hash=139228481, X=340, Y=231, Rot=15326, Flip=0, Var=0 }" & @CRLF & _
"傳送點 = { Hash=1224707366, X=298, Y=385, Rot=22179, Flip=0, Var=1 }" & @CRLF & _
"工藝台 = { Hash=2059629901, X=308, Y=288, Rot=32768, Flip=0, Var=4 }" & @CRLF & _
"黃金地球儀 = { Hash=2306038834, X=298, Y=227, Rot=0, Flip=0, Var=0 }" & @CRLF & _
"娜瓦莉 = { Hash=693228958, X=322, Y=260, Rot=32768, Flip=0, Var=0 }" & @CRLF & _
"埃哈 = { Hash=2684274993, X=325, Y=191, Rot=34826, Flip=0, Var=0 }" & @CRLF & _
"艾瓦 = { Hash=2115859440, X=265, Y=207, Rot=16384, Flip=0, Var=0 }" & @CRLF & _
"赫蓮娜 = { Hash=845403974, X=314, Y=238, Rot=47093, Flip=0, Var=0 }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")