// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"[^'":]*(("[^"]*"|'[^']*')[^'":]*)*"#).unwrap();
let string = "foo:\"01\":\"02\":\"03:04:05\":\"06:07:08:09\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}