re = /[^'":]*(("[^"]*"|'[^']*')[^'":]*)*/
str = 'foo:"01":"02":"03:04:05":"06:07:08:09"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end