package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^'":]*(("[^"]*"|'[^']*')[^'":]*)*`)
var str = `foo:"01":"02":"03:04:05":"06:07:08:09"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}