import Foundation
let pattern = #"<tagname((.|\n)(?!string))*?<\/tagname>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<?xml version="1.0" encoding="utf-8"?>
<OdfBody Source="IDS" DocumentCode="EQ0000000" Serial="869" Time="104139151" CompetitionCode="PG2016" Date="2016-09-02" FeedFlag="P" LogicalDate="2016-09-02" DocumentType="DT_PARTIC" Version="3" >
<Competition Code="PG2016">
<Participant Parent="1057257" MainFunctionId="AA01" OlympicSolidarity="N" Organisation="AUT" Code="1057257" BirthDate="1977-12-15" Nationality="AUT" Status="ACTIVE" TVName="Michael Martin KNAUDER" GivenName="Michael Martin" Gender="M" TVInitialName="M.M. KNAUDER" FamilyName="KNAUDER" PrintName="KNAUDER Michael Martin" PrintInitialName="KNAUDER MM" Current="true">
<Discipline IFId="10081843" Code="EQ">
<RegisteredEvent Event="001" Class="GIA" Gender="X">
<EventEntry Value="H014452" Type="ENTRY" Code="HORSE_ID"/>
<EventEntry Value="P 7" Type="ENTRY" Code="PROFILE"/>
</RegisteredEvent>
<RegisteredEvent Event="401" Class="GIA" Gender="X">
<EventEntry Value="H014452" Type="ENTRY" Code="HORSE"/>
<EventEntry Value="P 7" Type="ENTRY" Code="PROFILE"/>
</RegisteredEvent>
<RegisteredEvent Event="420" Class="GIA" Gender="X">
<EventEntry Value="H014452" Type="ENTRY" Code="HORSE_ID"/>
<EventEntry Value="P 7" Type="ENTRY" Code="PROFILE"/>
</RegisteredEvent>
</Discipline>
</Participant>
<Participant Parent="1063065" MainFunctionId="TM_OFFIC" OlympicSolidarity="N" Organisation="CZE" Code="1063065" BirthDate="1974-10-28" Nationality="CZE" Status="ACTIVE" TVName="Lenka MATOSKOVA" GivenName="Lenka" Gender="W" TVInitialName="L. MATOSKOVA" FamilyName="MATOSKOVA" PrintName="MATOSKOVA Lenka" PrintInitialName="MATOSKOVA L" Current="true">
<Discipline Code="EQ"/>
</Participant>
<Participant Parent="1096278" MainFunctionId="AA01" OlympicSolidarity="N" Organisation="AUT" Code="1096278" BirthDate="1995-09-24" Nationality="AUT" Status="ACTIVE" TVName="Julia SCIANCALEPORE" GivenName="Julia" Gender="W" TVInitialName="J. SCIANCALEPORE" FamilyName="SCIANCALEPORE" PrintName="SCIANCALEPORE Julia" PrintInitialName="SCIANCALEPORE J" Current="true">
<Discipline IFId="10108391" Code="EQ">
<RegisteredEvent Event="001" Class="GIA" Gender="X">
<EventEntry Value="H014366" Type="ENTRY" Code="HORSE_ID"/>
<EventEntry Value="P 12a" Type="ENTRY" Code="PROFILE"/>
</RegisteredEvent>
<RegisteredEvent Event="401" Class="GIA" Gender="X">
<EventEntry Value="H014366" Type="ENTRY" Code="HORSE"/>
<EventEntry Value="P 12a" Type="ENTRY" Code="PROFILE"/>
</RegisteredEvent>
<RegisteredEvent Event="420" Class="GIA" Gender="X">
<EventEntry Value="H014366" Type="ENTRY" Code="HORSE_ID"/>
<EventEntry Value="P 12a" Type="ENTRY" Code="PROFILE"/>
</RegisteredEvent>
</Discipline>
</Participant>
</Competition>
</OdfBody>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)