use strict;
my $str = '<?xml version="1.0" encoding="utf-8"?>
<OdfBody Source="IDS" DocumentCode="EQ0000000" Serial="869" Time="104139151" CompetitionCode="PG2016" Date="2016-09-02" FeedFlag="P" LogicalDate="2016-09-02" DocumentType="DT_PARTIC" Version="3" >
<Competition Code="PG2016">
<Participant Parent="1057257" MainFunctionId="AA01" OlympicSolidarity="N" Organisation="AUT" Code="1057257" BirthDate="1977-12-15" Nationality="AUT" Status="ACTIVE" TVName="Michael Martin KNAUDER" GivenName="Michael Martin" Gender="M" TVInitialName="M.M. KNAUDER" FamilyName="KNAUDER" PrintName="KNAUDER Michael Martin" PrintInitialName="KNAUDER MM" Current="true">
<Discipline IFId="10081843" Code="EQ">
<RegisteredEvent Event="001" Class="GIA" Gender="X">
<EventEntry Value="H014452" Type="ENTRY" Code="HORSE_ID"/>
<EventEntry Value="P 7" Type="ENTRY" Code="PROFILE"/>
</RegisteredEvent>
<RegisteredEvent Event="401" Class="GIA" Gender="X">
<EventEntry Value="H014452" Type="ENTRY" Code="HORSE"/>
<EventEntry Value="P 7" Type="ENTRY" Code="PROFILE"/>
</RegisteredEvent>
<RegisteredEvent Event="420" Class="GIA" Gender="X">
<EventEntry Value="H014452" Type="ENTRY" Code="HORSE_ID"/>
<EventEntry Value="P 7" Type="ENTRY" Code="PROFILE"/>
</RegisteredEvent>
</Discipline>
</Participant>
<Participant Parent="1063065" MainFunctionId="TM_OFFIC" OlympicSolidarity="N" Organisation="CZE" Code="1063065" BirthDate="1974-10-28" Nationality="CZE" Status="ACTIVE" TVName="Lenka MATOSKOVA" GivenName="Lenka" Gender="W" TVInitialName="L. MATOSKOVA" FamilyName="MATOSKOVA" PrintName="MATOSKOVA Lenka" PrintInitialName="MATOSKOVA L" Current="true">
<Discipline Code="EQ"/>
</Participant>
<Participant Parent="1096278" MainFunctionId="AA01" OlympicSolidarity="N" Organisation="AUT" Code="1096278" BirthDate="1995-09-24" Nationality="AUT" Status="ACTIVE" TVName="Julia SCIANCALEPORE" GivenName="Julia" Gender="W" TVInitialName="J. SCIANCALEPORE" FamilyName="SCIANCALEPORE" PrintName="SCIANCALEPORE Julia" PrintInitialName="SCIANCALEPORE J" Current="true">
<Discipline IFId="10108391" Code="EQ">
<RegisteredEvent Event="001" Class="GIA" Gender="X">
<EventEntry Value="H014366" Type="ENTRY" Code="HORSE_ID"/>
<EventEntry Value="P 12a" Type="ENTRY" Code="PROFILE"/>
</RegisteredEvent>
<RegisteredEvent Event="401" Class="GIA" Gender="X">
<EventEntry Value="H014366" Type="ENTRY" Code="HORSE"/>
<EventEntry Value="P 12a" Type="ENTRY" Code="PROFILE"/>
</RegisteredEvent>
<RegisteredEvent Event="420" Class="GIA" Gender="X">
<EventEntry Value="H014366" Type="ENTRY" Code="HORSE_ID"/>
<EventEntry Value="P 12a" Type="ENTRY" Code="PROFILE"/>
</RegisteredEvent>
</Discipline>
</Participant>
</Competition>
</OdfBody>';
my $regex = qr/<tagname((.|\n)(?!string))*?<\/tagname>/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}