import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<tagname((.|\\n)(?!string))*?<\\/tagname>";
final String string = "<?xml version=\"1.0\" encoding=\"utf-8\"?>\n"
+ "<OdfBody Source=\"IDS\" DocumentCode=\"EQ0000000\" Serial=\"869\" Time=\"104139151\" CompetitionCode=\"PG2016\" Date=\"2016-09-02\" FeedFlag=\"P\" LogicalDate=\"2016-09-02\" DocumentType=\"DT_PARTIC\" Version=\"3\" >\n"
+ " <Competition Code=\"PG2016\">\n"
+ " <Participant Parent=\"1057257\" MainFunctionId=\"AA01\" OlympicSolidarity=\"N\" Organisation=\"AUT\" Code=\"1057257\" BirthDate=\"1977-12-15\" Nationality=\"AUT\" Status=\"ACTIVE\" TVName=\"Michael Martin KNAUDER\" GivenName=\"Michael Martin\" Gender=\"M\" TVInitialName=\"M.M. KNAUDER\" FamilyName=\"KNAUDER\" PrintName=\"KNAUDER Michael Martin\" PrintInitialName=\"KNAUDER MM\" Current=\"true\">\n"
+ " <Discipline IFId=\"10081843\" Code=\"EQ\">\n"
+ " <RegisteredEvent Event=\"001\" Class=\"GIA\" Gender=\"X\">\n"
+ " <EventEntry Value=\"H014452\" Type=\"ENTRY\" Code=\"HORSE_ID\"/>\n"
+ " <EventEntry Value=\"P 7\" Type=\"ENTRY\" Code=\"PROFILE\"/>\n"
+ " </RegisteredEvent>\n"
+ " <RegisteredEvent Event=\"401\" Class=\"GIA\" Gender=\"X\">\n"
+ " <EventEntry Value=\"H014452\" Type=\"ENTRY\" Code=\"HORSE\"/>\n"
+ " <EventEntry Value=\"P 7\" Type=\"ENTRY\" Code=\"PROFILE\"/>\n"
+ " </RegisteredEvent>\n"
+ " <RegisteredEvent Event=\"420\" Class=\"GIA\" Gender=\"X\">\n"
+ " <EventEntry Value=\"H014452\" Type=\"ENTRY\" Code=\"HORSE_ID\"/>\n"
+ " <EventEntry Value=\"P 7\" Type=\"ENTRY\" Code=\"PROFILE\"/>\n"
+ " </RegisteredEvent>\n"
+ " </Discipline>\n"
+ " </Participant>\n"
+ " <Participant Parent=\"1063065\" MainFunctionId=\"TM_OFFIC\" OlympicSolidarity=\"N\" Organisation=\"CZE\" Code=\"1063065\" BirthDate=\"1974-10-28\" Nationality=\"CZE\" Status=\"ACTIVE\" TVName=\"Lenka MATOSKOVA\" GivenName=\"Lenka\" Gender=\"W\" TVInitialName=\"L. MATOSKOVA\" FamilyName=\"MATOSKOVA\" PrintName=\"MATOSKOVA Lenka\" PrintInitialName=\"MATOSKOVA L\" Current=\"true\">\n"
+ " <Discipline Code=\"EQ\"/>\n"
+ " </Participant>\n"
+ " <Participant Parent=\"1096278\" MainFunctionId=\"AA01\" OlympicSolidarity=\"N\" Organisation=\"AUT\" Code=\"1096278\" BirthDate=\"1995-09-24\" Nationality=\"AUT\" Status=\"ACTIVE\" TVName=\"Julia SCIANCALEPORE\" GivenName=\"Julia\" Gender=\"W\" TVInitialName=\"J. SCIANCALEPORE\" FamilyName=\"SCIANCALEPORE\" PrintName=\"SCIANCALEPORE Julia\" PrintInitialName=\"SCIANCALEPORE J\" Current=\"true\">\n"
+ " <Discipline IFId=\"10108391\" Code=\"EQ\">\n"
+ " <RegisteredEvent Event=\"001\" Class=\"GIA\" Gender=\"X\">\n"
+ " <EventEntry Value=\"H014366\" Type=\"ENTRY\" Code=\"HORSE_ID\"/>\n"
+ " <EventEntry Value=\"P 12a\" Type=\"ENTRY\" Code=\"PROFILE\"/>\n"
+ " </RegisteredEvent>\n"
+ " <RegisteredEvent Event=\"401\" Class=\"GIA\" Gender=\"X\">\n"
+ " <EventEntry Value=\"H014366\" Type=\"ENTRY\" Code=\"HORSE\"/>\n"
+ " <EventEntry Value=\"P 12a\" Type=\"ENTRY\" Code=\"PROFILE\"/>\n"
+ " </RegisteredEvent>\n"
+ " <RegisteredEvent Event=\"420\" Class=\"GIA\" Gender=\"X\">\n"
+ " <EventEntry Value=\"H014366\" Type=\"ENTRY\" Code=\"HORSE_ID\"/>\n"
+ " <EventEntry Value=\"P 12a\" Type=\"ENTRY\" Code=\"PROFILE\"/>\n"
+ " </RegisteredEvent>\n"
+ " </Discipline>\n"
+ " </Participant>\n"
+ " </Competition>\n"
+ "</OdfBody>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}