const regex = new RegExp('(?m)\\b[A-ZÀ-Ü][A-ZÀ-Ü ’\\']{2,}(?= |$)', 'gm')
const str = `DEL ?PRATO
DEL !PRATO
DEL PRATO!
DEL PRATO1
+DEL PRATO!
DEL? P!RATO
DEL? PRaTO
DEL aPRATO
DEL PRATOb
MARIO’APICELLA
MARIO’ APICELLA
MARIO ’ APICELLA
MARIO ’ ' APICELLA
ÒÌFÚ''' CIAOÙÜÒÌ'",
abcÒÌFÚ'
ÒÌFÚ' abcCIAOÙÜÒÌ'
abcÒÌFÚ' CIAOÙÜÒÌ
ÒÌFÚ'abc' CIAOÙÜÒÌ’
ÒÌFÚ' CIAOÙÜÒÌabc'
ÒÌFÚ' CIAOÙÜÒÌabc' ÒÌFÚ' CIAOÙÜÒÌabc'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}