#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)\b[A-ZÀ-Ü][A-ZÀ-Ü ’']{2,}(?= |$)"
Local $sString = "DEL ?PRATO" & @CRLF & _
"DEL !PRATO" & @CRLF & _
"DEL PRATO!" & @CRLF & _
"DEL PRATO1" & @CRLF & _
"+DEL PRATO!" & @CRLF & _
"DEL? P!RATO " & @CRLF & _
"DEL? PRaTO" & @CRLF & _
"DEL aPRATO" & @CRLF & _
"DEL PRATOb" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"MARIO’APICELLA" & @CRLF & _
"MARIO’ APICELLA" & @CRLF & _
"MARIO ’ APICELLA" & @CRLF & _
"MARIO ’ ' APICELLA" & @CRLF & _
"" & @CRLF & _
"ÒÌFÚ''' CIAOÙÜÒÌ'"," & @CRLF & _
"abcÒÌFÚ'" & @CRLF & _
"ÒÌFÚ' abcCIAOÙÜÒÌ'" & @CRLF & _
"abcÒÌFÚ' CIAOÙÜÒÌ" & @CRLF & _
"ÒÌFÚ'abc' CIAOÙÜÒÌ’" & @CRLF & _
"ÒÌFÚ' CIAOÙÜÒÌabc'" & @CRLF & _
"ÒÌFÚ' CIAOÙÜÒÌabc' ÒÌFÚ' CIAOÙÜÒÌabc'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")