using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)\b[A-ZÀ-Ü][A-ZÀ-Ü ’']{2,}(?= |$)";
string input = @"DEL ?PRATO
DEL !PRATO
DEL PRATO!
DEL PRATO1
+DEL PRATO!
DEL? P!RATO
DEL? PRaTO
DEL aPRATO
DEL PRATOb
MARIO’APICELLA
MARIO’ APICELLA
MARIO ’ APICELLA
MARIO ’ ' APICELLA
ÒÌFÚ''' CIAOÙÜÒÌ'"",
abcÒÌFÚ'
ÒÌFÚ' abcCIAOÙÜÒÌ'
abcÒÌFÚ' CIAOÙÜÒÌ
ÒÌFÚ'abc' CIAOÙÜÒÌ’
ÒÌFÚ' CIAOÙÜÒÌabc'
ÒÌFÚ' CIAOÙÜÒÌabc' ÒÌFÚ' CIAOÙÜÒÌabc'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}