import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)(?<!10)(?<!127)\\.(\\d+)(?<!192\\.168)(?<!172\\.(1[6-9]|2[0-9]|3[0-1]))\\.(\\d+)\\.(\\d+)";
final String string = "\n\n"
+ "No match\n"
+ "172.16.1.1\n"
+ "172.16.0.0\n"
+ "172.16.0.0\n"
+ "172.31.0.1\n"
+ "172.20.22.22\n"
+ "10.255.255.255\n"
+ "192.168.1.1\n"
+ "192.168.12.34\n"
+ "192.168.111.222\n"
+ "127.255.255.255\n"
+ "127.0.4.4\n"
+ "127.0.0.1\n"
+ "127.255.255.255\n"
+ "127.123.123.123\n"
+ "127.1.1.1\n"
+ "127.12.23.56\n\n"
+ "Match\n"
+ "172.15.2.2\n"
+ "172.33.33.33\n"
+ "192.167.1.1\n"
+ "192.169.1.1\n"
+ "207.168.207.11\n"
+ "207.168.207.22\n"
+ "192.2.199.199\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}